[BUGFIX] Fix message for install tool warning 09/26509/4
authorCynthia Mattingly <cm@marketing-factory.de>
Fri, 20 Dec 2013 10:06:52 +0000 (11:06 +0100)
committerMarkus Klein <klein.t3@mfc-linz.at>
Fri, 20 Dec 2013 12:47:09 +0000 (13:47 +0100)
Fix incorrect message for install tool login attempt warning.

Resolves: #54531
Releases: 6.2, 6.1
Change-Id: I40f34b85ffc554187baf1f2601c578cbaafc5718
Reviewed-on: https://review.typo3.org/26509
Reviewed-by: Markus Klein
Tested-by: Markus Klein
typo3/sysext/install/Classes/Controller/AbstractController.php

index fde7716..6a90e98 100644 (file)
@@ -306,8 +306,8 @@ class AbstractController {
                                ->setBody('There has been an Install Tool login attempt at TYPO3 site'
                                . ' \'' . $GLOBALS['TYPO3_CONF_VARS']['SYS']['sitename'] . '\''
                                . ' (' . GeneralUtility::getIndpEnv('HTTP_HOST') . ')'
-                               . ' The MD5 hash of the last 5 characters of the password tried was \'' . substr(md5($formValues['password']), -5) . '\''
-                               . ' remote addres was \'' . GeneralUtility::getIndpEnv('REMOTE_ADDR') . '\''
+                               . ' The last 5 characters of the MD5 hash of the password tried was \'' . substr(md5($formValues['password']), -5) . '\''
+                               . ' remote address was \'' . GeneralUtility::getIndpEnv('REMOTE_ADDR') . '\''
                                . ' (' . GeneralUtility::getIndpEnv('REMOTE_HOST') . ')')
                                ->send();
                }