[TASK] Allow Symfony 4 as constraint for composer 93/54893/4
authorBenni Mack <benni@typo3.org>
Thu, 7 Dec 2017 08:05:52 +0000 (09:05 +0100)
committerSusanne Moog <susanne.moog@typo3.org>
Sat, 9 Dec 2017 07:58:02 +0000 (08:58 +0100)
Symfony4 was released today, and using Symfony 4 components
should not be restricted.

The current used Symfony components (YAML, Finder, Console)
mainly concentrated on cleanup for the code.

For the bundled zip/tar.gz archives, nothing changes.

Resolves: #83180
Releases: master, 8.7
Change-Id: Ic518f3b7d3a94bd3b89587d4c8a07ed37c71cb38
Reviewed-on: https://review.typo3.org/54893
Reviewed-by: Stefan Neufeind <typo3.neufeind@speedpartner.de>
Tested-by: Stefan Neufeind <typo3.neufeind@speedpartner.de>
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Susanne Moog <susanne.moog@typo3.org>
Tested-by: Susanne Moog <susanne.moog@typo3.org>
composer.json
composer.lock

index fe16ce0..b091e04 100644 (file)
@@ -34,9 +34,9 @@
                "ext-xml": "*",
                "psr/log": "~1.0.0",
                "swiftmailer/swiftmailer": "~5.4.5",
-               "symfony/console": "^2.7 || ^3.0",
-               "symfony/finder": "^2.7 || ^3.0",
-               "symfony/yaml": "^2.7 || ^3.0",
+               "symfony/console": "^2.7 || ^3.0 || ^4.0",
+               "symfony/finder": "^2.7 || ^3.0 || ^4.0",
+               "symfony/yaml": "^2.7 || ^3.0 || ^4.0",
                "symfony/polyfill-mbstring": "^1.2",
                "doctrine/instantiator": "~1.0.4",
                "doctrine/annotations": "^1.3",
index 8a8114e..89d0a01 100644 (file)
@@ -4,7 +4,7 @@
         "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
         "This file is @generated automatically"
     ],
-    "content-hash": "4989f04866b3424b2848d38b7e7ec149",
+    "content-hash": "4c0c03e1d8cb80b05f541e6691629430",
     "packages": [
         {
             "name": "cogpowered/finediff",