[BUGFIX] Correct check for install tool requests in bootstrap 40/55740/2
authorSusanne Moog <susanne.moog@typo3.org>
Thu, 15 Feb 2018 18:32:49 +0000 (19:32 +0100)
committerBenni Mack <benni@typo3.org>
Thu, 15 Feb 2018 19:13:39 +0000 (20:13 +0100)
Resolves: #83924
Releases: master, 8.7
Change-Id: If9f435c64addea63793586e131da19768749857c
Reviewed-on: https://review.typo3.org/55740
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Benni Mack <benni@typo3.org>
Tested-by: Benni Mack <benni@typo3.org>
typo3/sysext/core/Classes/Core/Bootstrap.php

index 825fd08..45b148a 100644 (file)
@@ -650,7 +650,7 @@ class Bootstrap
                 $displayErrors = 1;
                 break;
             default:
-                if (!TYPO3_REQUESTTYPE_INSTALL) {
+                if (!(TYPO3_REQUESTTYPE & TYPO3_REQUESTTYPE_INSTALL)) {
                     // Throw exception if an invalid option is set.
                     throw new \RuntimeException(
                         'The option $TYPO3_CONF_VARS[SYS][displayErrors] is not set to "-1", "0" or "1".',