[BUGFIX] Split functional workspaces DataHandling test execution 89/28289/2
authorOliver Hader <oliver@typo3.org>
Wed, 12 Mar 2014 10:42:38 +0000 (11:42 +0100)
committerOliver Hader <oliver.hader@typo3.org>
Wed, 12 Mar 2014 11:11:21 +0000 (12:11 +0100)
Travis-CI stops after 10 minutes of not having received any data,
unfortunately it seems that the execution of the whole bunch of
functional workspaces tests takes longer,
see https://travis-ci.org/TYPO3/TYPO3.CMS/jobs/20590551

The "solution" is to explicitly split up these tests for
parallel execution in Travis-CI.

Resolves: #56806
Releases: 6.2
Change-Id: Ib5e67e6793adb9d7896ce89872ccfa080ca849bd
Reviewed-on: https://review.typo3.org/28289
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
typo3/sysext/core/Build/FunctionalTests.xml

index cf20531..d20604b 100644 (file)
                        <directory>../../../../typo3/sysext/impexp/Tests/Functional/</directory>
                </testsuite>
                <testsuite name="EXT:workspaces tests">
-                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/DataHandling/Group/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/DataHandling/IRRE/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/DataHandling/ManyToMany/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/DataHandling/Regular/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/DataHandling/Select/</directory>
+                       <directory>../../../../typo3/sysext/workspaces/Tests/Functional/Service/</directory>
                </testsuite>
                <testsuite name="EXT:extbase tests">
                        <directory>../../../../typo3/sysext/extbase/Tests/Functional/Relations</directory>