Fixed bug #13073: options.pageTree.showNavTitle = 1 does not work in typo3/browse_lin...
authorSteffen Gebert <steffen.gebert@typo3.org>
Wed, 8 Sep 2010 10:46:19 +0000 (10:46 +0000)
committerSteffen Gebert <steffen.gebert@typo3.org>
Wed, 8 Sep 2010 10:46:19 +0000 (10:46 +0000)
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@8769 709f56b5-9817-0410-a4d7-c38de5d9e867

ChangeLog
typo3/class.browse_links.php

index 5da5510..0a90179 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2010-09-08  Steffen Gebert  <steffen@steffen-gebert.de>
+
+       * Fixed bug #13073: options.pageTree.showNavTitle = 1 does not work in typo3/browse_links.php (Thanks to Sebastian Michaelsen)
+
 2010-09-06  Ernesto Baschny  <ernst@cron-it.de>
 
        * Fixed bug #15635: XHTML validity of backend when sys_action is loaded
index 1832db2..986cb31 100644 (file)
@@ -1424,6 +1424,8 @@ class browse_links {
                                $pagetree = t3lib_div::makeInstance('rtePageTree');
                                $pagetree->thisScript = $this->thisScript;
                                $pagetree->ext_showPageId = $GLOBALS['BE_USER']->getTSConfigVal('options.pageTree.showPageIdWithTitle');
+                               $pagetree->ext_showNavTitle = $GLOBALS['BE_USER']->getTSConfigVal('options.pageTree.showNavTitle');
+                               $pagetree->addField('nav_title');
                                $tree=$pagetree->getBrowsableTree();
                                $cElements = $this->expandPage();