[TASK] Follow-up for RTE: Remove support for IE 8 and older 01/36201/2
authorStanislas Rolland <typo3@sjbr.ca>
Fri, 23 Jan 2015 15:52:18 +0000 (10:52 -0500)
committerStanislas Rolland <typo3@sjbr.ca>
Fri, 23 Jan 2015 15:54:30 +0000 (16:54 +0100)
Releases: master
Resolves: #64445
Change-Id: I11cf58908a38bb3b3cf1aae3b6547abbff021f0e
Reviewed-on: http://review.typo3.org/36201
Reviewed-by: Stanislas Rolland <typo3@sjbr.ca>
Tested-by: Stanislas Rolland <typo3@sjbr.ca>
typo3/sysext/rtehtmlarea/Documentation/Introduction/Index.rst
typo3/sysext/rtehtmlarea/Resources/Public/JavaScript/HTMLArea/UserAgent/UserAgent.js
typo3/sysext/rtehtmlarea/htmlarea/locallang_dialogs.xlf
typo3/sysext/rtehtmlarea/locallang_csh.xlf

index 7e1bbb0..4792338 100644 (file)
@@ -22,11 +22,9 @@ The extension offers a Rich Text Editor or RTE with the following
 features:
 
 - Support for Firefox 1.5+, SeaMonkey 1.0+, Safari 3.0.4+, Google Chrome
-  1.0+ and Opera 9.62+ on all platforms, and for IE6.0+ on Windows
+  1.0+ and Opera 9.62+ on all platforms, and for IE 9.0+ on Windows
   platforms;
 
-- Based on the ExtJS JavaScript framework;
-
 - Integration of TYPO3 image insertion and link insertion browsers,
   configurable color selector and user element insertion dialog;
 
index 33d16bc..2f23622 100644 (file)
@@ -25,6 +25,7 @@ define('TYPO3/CMS/Rtehtmlarea/HTMLArea/UserAgent/UserAgent', [], function () {
                isIE6 = isIE && /msie 6/i.test(userAgent),
                isIE7 = isIE && (/msie 7/i.test(userAgent) || documentMode == 7),
                isIE8 = isIE && ((/msie 8/i.test(userAgent) && documentMode != 7) || documentMode == 8),
+               isIEBeforeIE9 = isIE6 || isIE7 || isIE8 || (isIE && typeof documentMode !== 'undefined' && documentMode < 9),
                isGecko = !isWebKit && !isIE && /gecko/i.test(userAgent),
                isiPhone = /iphone/i.test(userAgent),
                isiPad = /ipad/i.test(userAgent);
@@ -37,7 +38,7 @@ define('TYPO3/CMS/Rtehtmlarea/HTMLArea/UserAgent/UserAgent', [], function () {
                isIE6: isIE6,
                isIE7: isIE7,
                isIE8: isIE8,
-               isIEBeforeIE9: isIE6 || isIE7 || isIE8 || (isIE && typeof documentMode !== 'undefined' && documentMode < 9),
+               isIEBeforeIE9: isIEBeforeIE9,
                isGecko: isGecko,
                isGecko2: isGecko && /rv:1\.8/i.test(userAgent),
                isGecko3: isGecko && /rv:1\.9/i.test(userAgent),
index 118320b..079c60e 100644 (file)
                                <source>Browser support</source>
                        </trans-unit>
                        <trans-unit id="Mozilla_or_IE" xml:space="preserve">
-                               <source>For Firefox 1.5+, SeaMonkey 1.0+, Safari 3.0.4+, Google Chrome 1.0+ and Opera 9.62+ on any platform, and for Internet Explorer 6.0+ on Windows.</source>
+                               <source>For Firefox 1.5+, SeaMonkey 1.0+, Safari 3.0.4+, Google Chrome 1.0+ and Opera 9.62+ on any platform, and for Internet Explorer 9.0+ on Windows.</source>
                        </trans-unit>
                        <trans-unit id="product_documentation" xml:space="preserve">
                                <source>For more information, please visit:</source>
index 3ffb32c..11cb2ea 100644 (file)
@@ -7,10 +7,10 @@
                                <source>htmlArea RTE</source>
                        </trans-unit>
                        <trans-unit id=".description" xml:space="preserve">
-                               <source>htmlArea RTE is a free, open-source, ExtJS-based editor for &lt;textarea&gt; fields featuring tight integration with TYPO3.</source>
+                               <source>htmlArea RTE is a free, open-source editor for &lt;textarea&gt; fields featuring tight integration with TYPO3.</source>
                        </trans-unit>
                        <trans-unit id=".details" xml:space="preserve">
-                               <source>htmlArea RTE supports the following browsers: Firefox 1.5+, SeaMonkey 1.0+, Safari 3.0.4+, Google Chrome 1.0+ and Opera 9.62+ on any platform, and Internet Explorer 6.0+ on Windows.</source>
+                               <source>htmlArea RTE supports the following browsers: Firefox 1.5+, SeaMonkey 1.0+, Safari 3.0.4+, Google Chrome 1.0+ and Opera 9.62+ on any platform, and Internet Explorer 9.0+ on Windows.</source>
                        </trans-unit>
                        <trans-unit id=".seeAlso" xml:space="preserve">
                                <source>xEXT_rtehtmlarea_General:beUserSettings,