[BUGFIX] Raise minimum required prophecy version to 1.7.5 20/59620/6
authorBenjamin Franzke <bfr@qbus.de>
Sat, 2 Feb 2019 04:55:09 +0000 (05:55 +0100)
committerAnja Leichsenring <aleichsenring@ab-softlab.de>
Sat, 2 Feb 2019 10:28:10 +0000 (11:28 +0100)
commitf4a292cc73f08dc026406a84538586387338acb4
treec5844d939d534ef2dcb986499fcb6b149d294f69
parent4c0fd85fa51a769f3fb5a9744d58155c05dbdfce
[BUGFIX] Raise minimum required prophecy version to 1.7.5

The recently introduced `object` type declarations for extbase classes
require a minimum version of prophecy 1.7.5. Previous versions trigger
the following error:
  Scalar type declaration 'object' must be unqualified

Prophecy added support for object type declarations in 1.7.4 and
for return type object declarations in 1.7.5.

Therefore we add an explicit dev dependency to prophecy in composer.json
now (previously it was transitively required as ^1.7 by phpunit 7.1).

composer require --no-update --dev phpspec/prophecy:^1.7.5
composer update --lock

Releases: master
Resolves: #87622
Change-Id: Ic35db424d1ea46143839ec3f4bd3c10e39c99b4e
Reviewed-on: https://review.typo3.org/59620
Reviewed-by: Alexander Schnitzler <typo3@alexanderschnitzler.de>
Tested-by: Alexander Schnitzler <typo3@alexanderschnitzler.de>
Tested-by: TYPO3com <noreply@typo3.com>
Reviewed-by: Anja Leichsenring <aleichsenring@ab-softlab.de>
Tested-by: Anja Leichsenring <aleichsenring@ab-softlab.de>
composer.json
composer.lock
typo3/sysext/core/composer.json