[TASK] Raise PHP version requirement to 5.3.7 62/22662/3
authorChristian Kuhn <lolli@schwarzbu.ch>
Mon, 29 Jul 2013 15:53:03 +0000 (17:53 +0200)
committerStefan Neufeind <typo3.neufeind@speedpartner.de>
Wed, 31 Jul 2013 17:29:35 +0000 (19:29 +0200)
commitbb49c3363910ee9b15b4f29f37b0f5bf83d6a041
treeb4ebe92299a184ce8de3d77e3f1fee0e8a6a675f
parentc16837ac472675a7cc2c5236abe888dad3c04e22
[TASK] Raise PHP version requirement to 5.3.7

PHP versions smaller than 5.3.7 have some bugs that are worked
around with some nasty hacks in current core. It was already
decided on TYPO3 Active Contributor Meeting in Nuernberg to
not support these versions with the upcoming LTS that will have
to support so many different PHP versions already: Younger 5.3,
5.4, 5.5 and later on in the lifecycle of the product maybe even
more.

The patch drops compatibility code for versions smaller than 5.3.7.

Change-Id: I3344d797f0c2f23f5135257b98c1b05c80871399
Resolves: #50529
Releases: 6.2
Reviewed-on: https://review.typo3.org/22662
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
12 files changed:
INSTALL.txt
NEWS.txt
typo3/sysext/core/Classes/Charset/CharsetConverter.php
typo3/sysext/core/Classes/Compatibility/CompatbilityClassLoaderPhpBelow50307.php [deleted file]
typo3/sysext/core/Classes/Core/Bootstrap.php
typo3/sysext/core/Classes/Core/SystemEnvironmentBuilder.php
typo3/sysext/core/Tests/Unit/Cache/Backend/ApcBackendTest.php
typo3/sysext/core/Tests/Unit/Compatibility/CompatbilityClassLoaderPhpBelow50307Test.php [deleted file]
typo3/sysext/core/Tests/Unit/Locking/LockerTest.php
typo3/sysext/extbase/Classes/Utility/TypeHandlingUtility.php
typo3/sysext/frontend/Tests/Unit/Controller/DataSubmissionControllerTest.php
typo3/sysext/install/Classes/SystemEnvironment/Check.php