[BUGFIX] impexp: Wrong FAL references after import 67/55367/2
authorChristian Kuhn <lolli@schwarzbu.ch>
Mon, 15 Jan 2018 14:54:57 +0000 (15:54 +0100)
committerChristian Kuhn <lolli@schwarzbu.ch>
Mon, 15 Jan 2018 19:51:02 +0000 (20:51 +0100)
commit7585a53d35916edb3f909ca9aceee8e790829ae6
tree7f6d1d48dc42a6e24b8936543caa1e3c05c1e4b4
parent52c714d2544b9b26f217d191ccb0316eb2d30d8c
[BUGFIX] impexp: Wrong FAL references after import

Fix a case during ext:impexp FAL uid mapping where
sys_file_reference end up pointing to wrong sys_file
records in case new sys_file uids also already exist
in import file, due to multiple mappings.
Power the patch with a functional test - it fails
without the change in Import.php and is ok with the
change.
See the test method comments for more details
on what exactly is checked here.

Change-Id: I472cad2652e8d6f5d30e4ebc68ff1ae93de71ea1
Resolves: #67188
Releases: master, 8.7, 7.6
Reviewed-on: https://review.typo3.org/55367
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
typo3/sysext/impexp/Classes/Import.php
typo3/sysext/impexp/Tests/Functional/Fixtures/DatabaseAssertions/importPagesAndTtContentWithRemappingNewSysFileEntries.csv [new file with mode: 0644]
typo3/sysext/impexp/Tests/Functional/Fixtures/DatabaseImports/sys_file_single_image.xml [new file with mode: 0644]
typo3/sysext/impexp/Tests/Functional/Fixtures/XmlImports/pages-and-ttcontent-with-two-images.xml [new file with mode: 0644]
typo3/sysext/impexp/Tests/Functional/Import/PagesAndTtContentWithImagesInFilledDatabaseTest.php