[BUGFIX] Fix invalid HTML in ElementBrowser 41/41141/4
authorMarkus Klein <markus.klein@typo3.org>
Mon, 13 Jul 2015 18:55:44 +0000 (20:55 +0200)
committerBenjamin Mack <benni@typo3.org>
Mon, 13 Jul 2015 21:46:29 +0000 (23:46 +0200)
commit6dd63202bbcebfc35486247eabae421047ea35a7
tree43689aaf57388e8ede89aa29c78bdf27041b7132
parentfdc8234c2afe2316db5e43bf5ae3bfc0cdfc6823
[BUGFIX] Fix invalid HTML in ElementBrowser

An old implementations expected icons to be img-tags, which
is not the case anymore. The regex for replacing parts of the
tag do not work with the span tags anymore and therefore all
calls to the function are dropped.

This also renders a whole class useless, which is therefore removed
as well.

Resolves: #68086
Releases: master, 6.2
Change-Id: I073e6e2d640ac5f53ae13ec564e6f8903b65e8b8
Reviewed-on: http://review.typo3.org/41141
Reviewed-by: Benjamin Mack <benni@typo3.org>
Tested-by: Benjamin Mack <benni@typo3.org>
Reviewed-by: Benjamin Kott <info@bk2k.info>
Tested-by: Benjamin Kott <info@bk2k.info>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Wouter Wolters <typo3@wouterwolters.nl>
typo3/sysext/backend/Classes/Tree/View/BrowseTreeView.php
typo3/sysext/backend/Classes/Tree/View/ContentMovingPagePositionMap.php
typo3/sysext/backend/Classes/Tree/View/ElementBrowserPageTreeView.php
typo3/sysext/backend/Classes/Tree/View/FolderTreeView.php
typo3/sysext/backend/Classes/Tree/View/MoveElementPageTreeView.php [deleted file]
typo3/sysext/backend/Classes/Tree/View/NewRecordPageTreeView.php
typo3/sysext/backend/Classes/Tree/View/PageMovingPagePositionMap.php
typo3/sysext/compatibility6/Migrations/Code/ClassAliasMap.php