[BUGFIX] Don't download language packs of not loaded extensions 63/55863/2
authorChristian Kuhn <lolli@schwarzbu.ch>
Wed, 21 Feb 2018 23:05:49 +0000 (00:05 +0100)
committerChristian Kuhn <lolli@schwarzbu.ch>
Thu, 22 Feb 2018 11:28:11 +0000 (12:28 +0100)
commit62da5d3b17c409c27f4a780975fcaa8688ba2f8d
tree7622cdc6f196393cffd147049f4b8b4d5fa5754e
parent563420f56db08245c7fe640734970c349ffc343d
[BUGFIX] Don't download language packs of not loaded extensions

The backend language module struggles with downloading
language packs of existing, but not loaded extensions
and fetchess old (non core version specific) packs
for core extensions.
This is hard to solve on a bugfix level for v7 and v8,
and in general it does not make much sense to have
language packs of not loaded extensions lying around
in typo3conf/l10n.
The patch ignores fetching of language packs for
not loaded extensions, it easily applies to all
maintained core versions.

Change-Id: I9ad885012a572368f7946f1027d870ee09550034
Resolves: #83406
Releases: master, 8.7, 7.6
Reviewed-on: https://review.typo3.org/55863
Reviewed-by: Michael Stucki <michael.stucki@typo3.org>
Tested-by: Michael Stucki <michael.stucki@typo3.org>
Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
Tested-by: Christian Kuhn <lolli@schwarzbu.ch>
typo3/sysext/lang/Classes/Domain/Repository/ExtensionRepository.php