[FEATURE] Introduce Yarn and fix dependency handling and downgrade some libs 49/54749/3
authorBenjamin Kott <benjamin.kott@wfp2.com>
Fri, 24 Nov 2017 18:44:17 +0000 (19:44 +0100)
committerFrank Naegler <frank.naegler@typo3.org>
Sat, 25 Nov 2017 17:45:01 +0000 (18:45 +0100)
commit3b7c06e3b9e335b373349a3abe895a11619f4752
tree1aa58fc0a0fb337a28091e4a2960a78c930b7dc2
parente950ebedb966082c0cb326297fa56594f56087cc
[FEATURE] Introduce Yarn and fix dependency handling and downgrade some libs

Because of the broken dependency manager logic in NPM this patch introduce
yarn as dependency manager for node modules.
Also this patch downgrade some libs, which was updated accidentally in past.

To install node modules you have to install yarn first and call
`yarn install`, do not use `yarn update` until you really want
update a dependency.

Resolves: #83038
Releases: master, 8.7
Change-Id: I842636241d76b88f2b9e3836230fdb6629d22fc3
Reviewed-on: https://review.typo3.org/54749
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Frank Naegler <frank.naegler@typo3.org>
Tested-by: Frank Naegler <frank.naegler@typo3.org>
Build/Gruntfile.js
Build/package-lock.json [deleted file]
Build/package.json
Build/yarn.lock [new file with mode: 0644]
typo3/sysext/backend/Resources/Public/Css/backend.css
typo3/sysext/install/Resources/Public/Css/install.css