[BUGFIX] Fix wrong handling of php and TYPO3 dependencies 26/24126/2
authorSusanne Moog <typo3@susannemoog.de>
Sun, 8 Sep 2013 13:26:22 +0000 (15:26 +0200)
committerWouter Wolters <typo3@wouterwolters.nl>
Sat, 28 Sep 2013 17:34:01 +0000 (19:34 +0200)
commit3a3edf13adca6bcd5a5d90c65522f3a03cec5683
tree0976fab9d0a41ab7957fba4be417c7105dfe6c9f
parent9535891a2031948a60e638c6dd2035bda279a82b
[BUGFIX] Fix wrong handling of php and TYPO3 dependencies

Due to a superfluos try-catch block dependencies for TYPO3 and
PHP version were not checked correctly.

Additionally the TER version comparison was wrong as it did not
include the given version (only less or greater was checked, not
...OrEqual).

Resolves: #48809
Resolves: #51730
Resolves: #51182
Releases: 6.2, 6.1, 6.0
Change-Id: I773e1af014cd3e8525794c2fcdc615ea8a5f36a1
Reviewed-on: https://review.typo3.org/24126
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
typo3/sysext/extensionmanager/Classes/Controller/ActionController.php
typo3/sysext/extensionmanager/Classes/Domain/Repository/ExtensionRepository.php
typo3/sysext/extensionmanager/Classes/Utility/DependencyUtility.php