[BUGFIX] Double encoding in image title-tag 98/47898/3
authorFrank Naegler <frank.naegler@typo3.org>
Mon, 25 Apr 2016 12:16:31 +0000 (14:16 +0200)
committerOliver Hader <oliver.hader@typo3.org>
Tue, 26 Apr 2016 08:24:34 +0000 (10:24 +0200)
commit30d48182e2d61a8bf2171fa16f54e9a7c3c728bc
treecde48c21bd643a888650699a482d26d3102188c1
parent691545ddd1806ad730ffda4c6b0ff97dcec66773
[BUGFIX] Double encoding in image title-tag

With https://review.typo3.org/#/c/45284/ this bug was introduced. The change to
htmlSpecialChars = 1 was a mistake, because the output is already escaped.
This patch reverts the change for altText object.

Resolves: #75860
Releases: master, 7.6, 6.2
Change-Id: I87ea6ef4c734707933c75ab5c9ab3c4f4604251d
Reviewed-on: https://review.typo3.org/47898
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Wouter Wolters <typo3@wouterwolters.nl>
Reviewed-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Tested-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Reviewed-by: Andreas Fernandez <typo3@scripting-base.de>
Reviewed-by: Nicole Cordes <typo3@cordes.co>
Tested-by: Nicole Cordes <typo3@cordes.co>
Reviewed-by: Michael Oehlhof <typo3@oehlhof.de>
Reviewed-by: Jigal van Hemert <jigal.van.hemert@typo3.org>
Tested-by: Jigal van Hemert <jigal.van.hemert@typo3.org>
Reviewed-by: Oliver Hader <oliver.hader@typo3.org>
Tested-by: Oliver Hader <oliver.hader@typo3.org>
typo3/sysext/css_styled_content/Configuration/TypoScript/v7/setup.txt
typo3/sysext/css_styled_content/static/setup.txt