[TASK] Remove outdated upgrade wizards 76/26776/7
authorSteffen Ritter <info@rs-websystems.de>
Mon, 13 Jan 2014 09:25:16 +0000 (10:25 +0100)
committerWouter Wolters <typo3@wouterwolters.nl>
Mon, 24 Feb 2014 21:25:32 +0000 (22:25 +0100)
commit2e1c368ac7fe83a87c2a5327b47a21d2a498a8d9
treeeb2447c2193d47893b9fc392aee5a86ec8819632
parent69408211e47283cb50ae8896101e05de42963a7a
[TASK] Remove outdated upgrade wizards

The core ships upgrade wizards for all versions since TYPO3 CMS 4.2.
Users upgrading to TYPO3 CMS 6.2 LTS should have at least TYPO3 4.5 LTS
or later. Therefore all Upgrade-Wizards which already have been executed
to upgrade to TYPO3 CMS 4.5 LTS and below can be safely removed for the
current LTS.

This change removed all these wizards relating to changes in 4.2, 4.3 and
4.5.

Resolves: #54930
Releases: 6.2
Change-Id: Ia691e3ca7dd347c6748a8e9d753278b2247f75b9
Reviewed-on: https://review.typo3.org/26776
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
15 files changed:
INSTALL.md
typo3/sysext/install/Classes/Service/SilentConfigurationUpgradeService.php
typo3/sysext/install/Classes/Updates/AddFlexFormsToAclUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/CharsetDefaultsUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/CompressionLevelUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/CscSplitUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/FlagsFromSpriteUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/ImagecolsUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/ImagelinkUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/InstallSysExtsUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/MergeAdvancedUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/MigrateWorkspacesUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/NotInMenuUpdate.php [deleted file]
typo3/sysext/install/Classes/Updates/T3skinUpdate.php [deleted file]
typo3/sysext/install/ext_localconf.php