[TASK] Add support for "outdated" extensions
[Packages/TYPO3.CMS.git] / typo3 / sysext / extensionmanager / Resources / Private / Templates / List / Index.html
index c8ace0d..4e53e54 100644 (file)
@@ -38,7 +38,7 @@
                        <f:for each="{extensions}" as="extension" key="extensionKey">
                                <f:if condition="{extension.terObject}">
                                        <f:then>
-                                               <tr id="{extensionKey}" class="{f:if(condition:'{extension.terObject.reviewState} >= 0', then:'', else:'insecure')} {f:if(condition:'{extension.installed}', then: '', else: 'inactive')}">
+                                               <tr id="{extensionKey}" class="{f:if(condition:'{extension.terObject.reviewState} == -1', then:'insecure')}{f:if(condition:'{extension.terObject.reviewState} == -2', then:'outdated')} {f:if(condition:'{extension.installed}', then: '', else: 'inactive')}">
                                        </f:then>
                                        <f:else>
                                                <tr id="{extensionKey}" class="{f:if(condition:'{extension.installed}', then: '', else: 'inactive')}">