[BUGFIX] Remove empty brackets when configuration type is unknown
[Packages/TYPO3.CMS.git] / INSTALL.txt
index f8e7ef0..7990017 100644 (file)
@@ -38,10 +38,12 @@ The following configuration is the minimum required:
        Some extensions can be optionally compiled into PHP. A list of loaded
        extensions can be checked using the phpinfo() function.
 - memory_limit set to at least 64M in php.ini
+- register_globals is disabled in php.ini
 - MySQL 5.0 or newer
 - 200 MB of disk space
 - AllowOverride in the Apache configuration includes "Indexes" and "FileInfo"
   (see FAQ below)
+- Apache stack size 8MB (or more). (see FAQ below)
 
 The following configuration is recommended:
 - Apache 2.x
@@ -81,7 +83,7 @@ simulate random number generation. This is less secure, causes performance
 issues and warnings in the TYPO3 system log.
 
 TYPO3 relies on IPv6 support, which is by default enabled since PHP 5.3.
-Take care not to compile PHP 5.3 with the option "--disablr_ipv6", because
+Take care not to compile PHP 5.3 with the option "--disable-ipv6", because
 this will break the IPv6 support and the according unit tests.
 
 ===============================================================================
@@ -232,6 +234,16 @@ A: If you use MySQL 5.x or newer, try setting it to "compatible" mode. Open the
        and add this line to the top of the input field:
                SET SESSION sql_mode='MYSQL40'
 
+Q:     Some modules or extensions make Apache crash on Windows. What is the cause?
+A:     Fluid uses complex regular expressions which require a lot of stack space
+       during the first processing. On Windows the default stack size for Apache
+       is a lot smaller than on unix. You can increase the size to 8MB (default on
+       unix) by adding to the httpd.conf:
+               <IfModule mpm_winnt_module>
+                       ThreadStackSize 8388608
+               </IfModule>
+       Restart Apache after this change.
+
 Q:     What do I have to do regarding security?
 A:     You have to make sure that you keep your TYPO3-core and the extensions
        up to date.
@@ -244,4 +256,4 @@ A:  You have to make sure that you keep your TYPO3-core and the extensions
          of these extensions are available and install them respectively.
        * For further reading regarding securing TYPO3, please read the TYPO3 security
          cookbook and other resources. Please visit
-         http://typo3.org/teams/security/resources/
\ No newline at end of file
+         http://typo3.org/teams/security/resources/