[BUGFIX] Empty item group in selectElement
[Packages/TYPO3.CMS.git] / .travis.yml
index 95dde70..ba9dfa2 100644 (file)
@@ -1,62 +1,78 @@
 language: php
 
-php:
-  - 5.3
-  - 5.4
-  - 5.5
+matrix:
+  allow_failures:
+    - php: 7
 
-env:
-  - DB=mysql UNITTESTS=1
-  - DB=none FUNCTIONALTESTS=1
-  - DB=none PHPLINT=1
+  include:
+    - php: 5.5
+      env: UNIT_TESTS=yes FUNCTIONAL_TESTS=yes PHP_LINT=yes XLF_CHECK=yes SUBMODULE_TEST=yes
+    - php: 5.6
+      env: UNIT_TESTS=yes FUNCTIONAL_TESTS=yes PHP_LINT=yes
+    - php: 7
+      env: UNIT_TESTS=yes
 
 services:
   - memcached
+  - redis-server
+
+notifications:
+  irc:
+    channels:
+      - "irc.freenode.net#typo3-cms"
+    on_success: change
+    on_failure: always
+    use_notice: true
+  slack:
+    rooms:
+      secure: nHWVTPyG3CQWIcYA1LASS11dD0/NBcmrAyr3xxQW0XYtH47ZUKRlEtxrVLuL7ptciNwMbfZgsiRQ1QGWDerHUlBkg0iwRxpUZgeylzWaiXsHFVAp2IBfEX54KrWeYm9gewIBDDtnp+sLgpXGgmpIs2bAGkZe5129UsUExoWh0+g=
+    on_success: change
+    on_failure: always
 
 before_script:
-  - git clone --single-branch --branch master --depth 1 git://github.com/typo3-ci/TYPO3-Travis-Integration.git build-environment
-  - source build-environment/install-helper.sh
+  - if [ -e ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini ]; then echo "extension = memcache.so" >> ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini; fi
+  - if [ -e ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini ]; then echo "extension = redis.so" >> ~/.phpenv/versions/$(phpenv version-name)/etc/php.ini; fi
+  - sudo apt-get install parallel
+  - rm -rf typo3/sysext/compatibility6
+  - composer self-update
+  - composer install
 
+script:
   - >
-    if [[ "$UNITTESTS" == "1" ]]; then
-       if [[ "$TRAVIS_PHP_VERSION" == "5.3" ]]; then
-               installPhpModule -y apc;
-       fi
-       if [[ "$TRAVIS_PHP_VERSION" != "5.5" ]]; then
-               installPhpModule igbinary
-       fi
-       installPhpModule -y memcache
-       installPhpModule redis
-       mv build-environment/typo3conf .
-       git clone --single-branch --branch master --depth 1 git://git.typo3.org/TYPO3v4/Extensions/phpunit.git typo3conf/ext/phpunit/
-       mkdir fileadmin
-       mkdir uploads
-       mkdir typo3temp
+    if [[ "$UNIT_TESTS" == "yes" ]]; then
+      echo;
+      echo "Running unit tests";
+      ./bin/phpunit --colors -c typo3/sysext/core/Build/UnitTests.xml
     fi
-
   - >
-    if [[ "$FUNCTIONALTESTS" == "1" ]]; then
-       mv build-environment/typo3conf .
-       git clone --single-branch --branch master --depth 1 git://git.typo3.org/TYPO3v4/Extensions/phpunit.git typo3conf/ext/phpunit/
-       mkdir typo3temp
+    if [[ "$FUNCTIONAL_TESTS" == "yes" ]]; then
+        echo;
+        export typo3DatabaseName="typo3";
+        export typo3DatabaseHost="localhost";
+        export typo3DatabaseUsername="root";
+        export typo3DatabasePassword="";
+        find . -wholename '*typo3/sysext/*/Tests/Functional/*Test.php' | parallel --gnu 'echo; echo "Running functional test suite {}"; ./bin/phpunit --colors -c typo3/sysext/core/Build/FunctionalTests.xml {}'
     fi
-
   - >
-    if [[ "$DB" == "mysql" ]]; then
-       mysql -e "DROP DATABASE IF EXISTS typo3_test;" -uroot
-       mysql -e "CREATE DATABASE IF NOT EXISTS typo3_test;" -uroot
-       php build-environment/dbimport/DatabaseImport.php
-       mysql -uroot typo3_test < build-environment/dbimport/cli_users.sql
+    if [[ "$PHP_LINT" == "yes" ]]; then
+        echo;
+        echo "Running php lint";
+        find typo3/ -name \*.php -not -path "typo3/contrib/vendor/*" | parallel --gnu php -d display_errors=stderr -l {} > /dev/null \;
+    fi
+  - >
+    if [[ "$XLF_CHECK" == "yes" ]]; then
+        echo;
+        echo "Running XLF checker";
+        ./typo3/sysext/core/Build/Scripts/xlfcheck.sh
     fi
-
-script:
   - >
-    if [[ "$PHPLINT" == "1" ]]; then
-       phpLint all
-    elif [[ "$UNITTESTS" == "1" ]]; then
-       php $PWD/typo3/cli_dispatch.phpsh phpunit -c typo3/sysext/core/Build/UnitTests.xml
-    elif [[ "$FUNCTIONALTESTS" == "1" ]]; then
-       ./typo3conf/ext/phpunit/Composer/vendor/bin/phpunit -c typo3/sysext/core/Build/FunctionalTests.xml
-    else
-       exit 1
-    fi
\ No newline at end of file
+      if [[ "$SUBMODULE_TEST" == "yes" ]]; then
+          echo;
+          echo "Running git submodule check";
+          /bin/bash -c "
+              if [[ `git submodule status 2>&1 | wc -l` -ne 0 ]]; then
+                  echo \"Found a submodule definition in repository\";
+                  exit 99;
+              fi
+          "
+      fi