Fixed bug #15282: It is impossible to set links to files any more with the link wizard
[Packages/TYPO3.CMS.git] / t3lib / class.t3lib_tceforms.php
index 6e62370..2bd17ea 100644 (file)
@@ -2730,8 +2730,8 @@ class t3lib_TCEforms      {
 
                                                                        // Makes a "Add new" link:
                                                                $var = uniqid('idvar');
-                                                               $replace = 'replace(/' . $idTagPrefix . '-/g,"' . $idTagPrefix . '"+' . $var . '+"-")';
-                                                               $onClickInsert = 'var ' . $var . ' = "' . $idTagPrefix . '-idx"+(new Date()).getTime();';
+                                                               $replace = 'replace(/' . $idTagPrefix . '-/g,"' . $idTagPrefix . '-"+' . $var . '+"-")';
+                                                               $onClickInsert = 'var ' . $var . ' = "' . 'idx"+(new Date()).getTime();';
                                                                // Do not replace $isTagPrefix in setActionStatus() because it needs section id!
                                                                $onClickInsert .= 'new Insertion.Bottom($("'.$idTagPrefix.'"), unescape("'.rawurlencode($newElementTemplate).'").' . $replace . '); setActionStatus("'.$idTagPrefix.'");';
                                                                $onClickInsert .= 'eval(unescape("' . rawurlencode(implode(';', $this->additionalJS_post)) . '").' . $replace . ');';