Fixed bug #9046: Nested domain linking
[Packages/TYPO3.CMS.git] / typo3 / sysext / cms / tbl_cms.php
index ba7c1fe..2458617 100755 (executable)
@@ -274,8 +274,8 @@ $TCA['fe_users'] = array(
                        'config' => array(
                                'type' => 'input',
                                'readOnly' => '1',
-                               'size' => '8',
-                               'eval' => 'date'
+                               'size' => '12',
+                               'eval' => 'datetime',
                        )
                )
        ),
@@ -453,10 +453,18 @@ $TCA['sys_domain'] = array(
                                'type' => 'check',
                                'default' => '0'
                        )
+               ),
+               'forced' => array(
+                       'label' => 'LLL:EXT:cms/locallang_tca.php:sys_domain.forced',
+                       'exclude' => 1,
+                       'config' => array(
+                               'type' => 'check',
+                               'default' => '1'
+                       )
                )
        ),
        'types' => array(
-               '1' => array('showitem' => 'hidden;;;;1-1-1,domainName;;1;;3-3-3,prepend_params')
+               '1' => array('showitem' => 'hidden;;;;1-1-1,domainName;;1;;3-3-3,prepend_params,forced;;;;4-4-4')
        ),
        'palettes' => array(
                '1' => array('showitem' => 'redirectTo, redirectHttpStatusCode')