Follow up to #13379: Removed generation parts of Sprite Icon API (Thanks to Steffen...
[Packages/TYPO3.CMS.git] / ChangeLog
index 4a61a18..a922dec 100755 (executable)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,149 @@
+2010-05-22  Oliver Hader  <oliver@typo3.org>
+
+       * Added feature #13868: Integrate TYPO3 donate notice in the backend
+
+2010-05-22  Benjamin Mack  <benni@typo3.org>
+
+       * Follow up to #13379: Removed generation parts of Sprite Icon API (Thanks to Steffen Ritter)
+       * Fixed bug #12923: Javascript error in tmenu_layers.php & gmenu_layers.php (Thanks to Klaus Goessl)
+
+2010-05-22  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14191: Install tool lacks hint of how to create ENABLE_INSTALL_TOOL (thanks to Steffen Gebert)
+       * Fixed bug #14328: Include prototype+scriptaculous using API at the login screen (thanks to Steffen Gebert)
+       * Added Feature #14324: Add spriteGeneratorAPI to support the new sprite-icon-API (thanks to Steffen Ritter)
+
+2010-05-22  Xavier Perseguers  <typo3@perseguers.ch>
+
+       * Fixed bug #14175: belog not shown / error when actions: error is selected (thanks to Philipp Thiele)
+
+2010-05-21  Benjamin Mack  <benni@typo3.org>
+
+       * Fixed bug #14443: Deprecate $TYPO3_CONF_VARS[GFX][TTFLocaleConv]
+       * Cleaned up #9416: Code Cleanup for lang.php (Thanks to Stefano Kowalke)
+       * Fixed bug #6555: template.relPathPrefix causes decoding of html-entities in affected attributes (Thanks to Martin Ficzel)
+       * Fixed bug #13749: IRRE: Inline elements of translated records are not coppied correctly. (Thanks to Albrecht Koehnlein)
+
+2010-05-20  Christian Kuhn  <lolli@schwarzbu.ch>
+
+       * Fixed bug #7753: EM warns No XCLASS inclusion code found if you use $GLOBALS['TYPO3_CONF_VARS'] (thanks to Franz Holzinger)
+
+2010-05-19  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Follow-up to bug #14413: htmlArea RTE: ExtJS resources are not released in IE when RTE closes
+
+2010-05-18  Benjamin Mack  <benni@typo3.org>
+
+       * Follow-up to #14277: Removed redundant code / Improve t3lib_compressor
+
+2010-05-18  Ernesto Baschny  <ernst@cron-it.de>
+
+       * Follow-up to bug #13670: Wrong variable name causing EM not to show "Extensions found only on this server" on "Import extensions" search result
+
+2010-05-18  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14327: Condition misses check for no logged in user
+
+2010-05-17  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Fixed bug #14413: htmlArea RTE: ExtJS resources are not released in IE when RTE closes
+
+2010-05-17  Christian Kuhn  <lolli@schwarzbu.ch>
+
+       * Fixed bug #14411: Use of deprecated method t3lib_BEfunc::getSetUpdateSignal in impexp
+       * Follow-up to bug #13670: Fatal in t3lib_querygenerator
+       * Follow-up to bug #13670: Fatal in fe_adminLib.inc (thanks to Lars Houmark)
+
+2010-05-16  Christian Kuhn  <lolli@schwarzbu.ch>
+
+       * Follow-up to bug #13670: #14393 Fatal error in impexp
+
+2010-05-16  Steffen Kamper  <info@sk-typo3.de>
+
+       * Follow-up to bug #13670: Performance optimization: change while(list() to foreach()
+
+2010-05-15  Christian Kuhn  <lolli@schwarzbu.ch>
+
+       * Fixed bug #14312: Notice undefined index systemLog and undefined constant TYPO3_ERRORHANDLER_MODE (thanks to Martin Mueller)
+       * Fixed bug #14309: Notice undefined index "error" & "debug" in index_ts.php (thanks to Martin Müller)
+       * Fixed bug #14180: No Message shown when accessing backend if TYPO3_CONF_VARS[BE][adminOnly] = -1 (thanks to Georg Ringer)
+
+2010-05-14  Ernesto Baschny  <ernst@cron-it.de>
+
+       * Fixed bug #14337: "The install tool is locked" doesn't send no-cache headers (thanks to Steffen Gebert)
+
+2010-05-14  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14339: Better options for deprecation log
+       * Fixed bug #14375: Rewrite of the debug panel (More Features!, More Stability!, More Usability!) (Stefan Galinski)
+       * Follow-up to bug #14365: Bug: Install Tool skin is sometimes wrong (thanks to Lars Houmark)
+       * Fixed bug #14367: Install Tool does not provide a logout possibility (thanks to Lars Houmark)
+
+2010-05-13  Ernesto Baschny  <ernst@cron-it.de>
+
+       * Fixed issue #13670: Performance optimization: change while(list() to foreach() (thanks to Georg Ringer and Steffen Gebert)
+
+2010-05-13  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #12803: Creating or deleting ENABLE_INSTALL_TOOL file saves settings in "User Settings"
+       * Fixed bug #14341: c&p error in t3lib_div::logDeprecatedFunction
+       * Fixed bug #14365: Bug: Install Tool skin is sometimes wrong (thanks to Lars Houmark)
+       * Fixed bug #14336: Merge modules "Cleanup and typo3temp/" of the Install Tool (thanks to Steffen Gebert)
+
+2010-05-13  Patrick Broens  <patrick@patrickbroens.nl>
+
+       * Fixed bug #14379: CSS issues for Internet Explorer version 6 and 7 (thanks to Jigal van Hemert)
+
+2010-05-12  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Follow-up to bug #14360: htmlArea RTE: Toolbar and context menu styling needs adjustments
+       * Fixed bug #14374: htmlArea RTE: Language plugin may cause js error on RTE initialization
+
+2010-05-12  Dmitry Dulepov  <dmitry.dulepov@gmail.com>
+
+       * Fixed bug #14052: cache_treelist is out of date after setting hidden=0 (thanks to Steffen Gebert)
+
+2010-05-10  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Fixed bug #9455: RTE incorrectly modifies external links and causes problems with subdomains
+       * Fixed bug #14360: htmlArea RTE: Toolbar and context menu styling needs adjustments
+
+2010-05-07  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14335: Install Tool buttons have no hover state (thanks to Steffen Gebert)
+
+2010-05-09  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Follow-up to feature #14014: htmlArea RTE should use version numbering method for CSS and JS files
+       * Fixed bug #14349: htmlArea RTE: Unavailability of hot key map may cause plugin to fail
+       * Follow-up to feature #14277: Apply gzip compression to htmlArea RTE concatenated js script
+       * Follow-up to feature #14014: Some htmlArea RTE csss files are not versioned in the FE
+
+2010-05-07  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14326: [Performance] Preload ExtJS in BE
+       * Fixed bug #14288: opendocs can cause duplicate id html errors (thanks to Stefan Galinski)
+
+2010-05-07  Stanislas Rolland  <typo3@sjbr.ca>
+
+       * Fixed bug #14202: htmlArea RTE: Tables may get lost when using remove format feature
+
+2010-05-07  Susanne Moog  <typo3@susanne-moog.de>
+
+       * Fixed bug #14293: IRRE loading indicator makes label text jump (Thanks to Lars Houmark)
+
+2010-05-07  Benjamin Mack  <benni@typo3.org>
+
+       * Fixed bug #5003: prefixRelPath() incorrectly changes links to anchors (Thanks to Jigal van Hemert)
+
+2010-05-07  Oliver Hader  <oliver@typo3.org>
+
+       * Fixed bug #13495: Workspace tiled Preview shows same version of Page
+
+2010-05-07  Steffen Kamper  <info@sk-typo3.de>
+
+       * Fixed bug #14331: BE search is broken
+
 2010-05-06  Benjamin Mack  <benni@typo3.org>
 
        * Fixed bug #14028: Code cleanup in class.t3lib_userauthgroup.php - part 1: foreach loops / variable renaming (Thanks to Kjeld Schumacher)
 2010-05-06  Benjamin Mack  <benni@typo3.org>
 
        * Fixed bug #14028: Code cleanup in class.t3lib_userauthgroup.php - part 1: foreach loops / variable renaming (Thanks to Kjeld Schumacher)