[BUGFIX] Fix T3editor after PSR-7 change
[Packages/TYPO3.CMS.git] / typo3 / sysext / openid / ext_tables.php
index d84049b..e260ff1 100644 (file)
@@ -1,24 +1,16 @@
 <?php
-// Make sure that we are executed only from the inside of TYPO3
-if (!defined('TYPO3_MODE')) {
-       die('Access denied.');
-}
+defined('TYPO3_MODE') or die();
 
 if (TYPO3_MODE === 'BE') {
-       // Register wizard
-       \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addModulePath(
-               'wizard_openid',
-               \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::extPath($_EXTKEY) . 'wizard/'
-       );
 
-       // Add field to setup module
-       $GLOBALS['TYPO3_USER_SETTINGS']['columns']['tx_openid_openid'] = array(
-               'type' => 'user',
-               'table' => 'be_users',
-               'label' => 'LLL:EXT:openid/locallang_db.xlf:_MOD_user_setup.tx_openid_openid',
-               'csh' => 'tx_openid_openid',
-               'userFunc' => 'TYPO3\\CMS\\Openid\\OpenidModuleSetup->renderOpenID',
-               'access' => 'TYPO3\\CMS\\Openid\\OpenidModuleSetup'
-       );
-       \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addFieldsToUserSettings('tx_openid_openid', 'after:password2');
+    // Add field to setup module
+    $GLOBALS['TYPO3_USER_SETTINGS']['columns']['tx_openid_openid'] = array(
+        'type' => 'user',
+        'table' => 'be_users',
+        'label' => 'LLL:EXT:openid/locallang_db.xlf:_MOD_user_setup.tx_openid_openid',
+        'csh' => 'tx_openid_openid',
+        'userFunc' => \FoT3\Openid\OpenidModuleSetup::class . '->renderOpenID',
+        'access' => \FoT3\Openid\OpenidModuleSetup::class
+    );
+    \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addFieldsToUserSettings('tx_openid_openid', 'after:password2');
 }