[BUGFIX] Use proper import statement in ErrorController
[Packages/TYPO3.CMS.git] / typo3 / sysext / taskcenter / ext_tables.php
index af9a6cb..7bac1c9 100644 (file)
@@ -1,18 +1,16 @@
 <?php
-if (!defined('TYPO3_MODE')) {
-       die('Access denied.');
-}
-if (TYPO3_MODE === 'BE') {
-       \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addModulePath(
-               'tools_txtaskcenterM1',
-               \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::extPath($_EXTKEY) . 'task/'
-       );
-       \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addModule(
-               'user',
-               'task',
-               'top',
-               \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::extPath($_EXTKEY) . 'task/'
-       );
-       $GLOBALS['TYPO3_CONF_VARS']['BE']['AJAX']['Taskcenter::saveCollapseState'] = 'TYPO3\\CMS\\Taskcenter\\TaskStatus->saveCollapseState';
-       $GLOBALS['TYPO3_CONF_VARS']['BE']['AJAX']['Taskcenter::saveSortingState'] = 'TYPO3\\CMS\\Taskcenter\\TaskStatus->saveSortingState';
-}
+defined('TYPO3_MODE') or die();
+
+\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addModule(
+    'user',
+    'task',
+    'top',
+    '',
+    [
+        'routeTarget' => \TYPO3\CMS\Taskcenter\Controller\TaskModuleController::class . '::mainAction',
+        'access' => 'group,user',
+        'name' => 'user_task',
+        'icon' => 'EXT:taskcenter/Resources/Public/Icons/module-taskcenter.svg',
+        'labels' => 'LLL:EXT:taskcenter/Resources/Private/Language/locallang_mod.xlf'
+    ]
+);