Fixed bug #11884: User setup: buttons for create/delete ENABLE_INSTALL_TOOL-file...
[Packages/TYPO3.CMS.git] / typo3 / sysext / setup / ext_tables.php
index 9d58deb..aceb9ef 100755 (executable)
@@ -155,11 +155,18 @@ $GLOBALS['TYPO3_USER_SETTINGS'] = array(
                        'label' => 'LLL:EXT:setup/mod/locallang.xml:resizeTextareas_Flexible',
                        'csh' => 'resizeTextareas_Flexible',
                ),
+               'installToolEnableButton' => array(
+                       'type' => 'user',
+                       'label' => 'LLL:EXT:setup/mod/locallang.xml:enableInstallTool.label',
+                       'userFunc' => 'SC_mod_user_setup_index->renderInstallToolEnableFileButton',
+                       'access' => 'admin',
+                       'csh' => 'enableInstallTool'
+               ),
        ),
        'showitem' => '--div--;LLL:EXT:setup/mod/locallang.xml:personal_data,realName,email,emailMeAtLogin,password,password2,lang,
                        --div--;LLL:EXT:setup/mod/locallang.xml:opening,condensedMode,noMenuMode,startModule,thumbnailsByDefault,helpText,edit_showFieldHelp,titleLen,
                        --div--;LLL:EXT:setup/mod/locallang.xml:editFunctionsTab,edit_RTE,edit_wideDocument,edit_docModuleUpload,enableFlashUploader,resizeTextareas,resizeTextareas_MaxHeight,resizeTextareas_Flexible,disableCMlayers,copyLevels,recursiveDelete,
-                       --div--;LLL:EXT:setup/mod/locallang.xml:adminFunctions,simulate'
+                       --div--;LLL:EXT:setup/mod/locallang.xml:adminFunctions,simulate,installToolEnableButton'
 
 );
 ?>
\ No newline at end of file