[TASK] Migrate DatabaseConnection->cleanIntList
[Packages/TYPO3.CMS.git] / composer.json
index 37f5406..5e815d1 100644 (file)
@@ -9,7 +9,7 @@
                {
                        "name": "TYPO3 CMS Core Team",
                        "role": "Developer",
-                       "homepage": "http://forge.typo3.org/projects/typo3cms-core"
+                       "homepage": "https://forge.typo3.org/projects/typo3cms-core"
                },
                {
                        "name": "The TYPO3 Community",
@@ -19,7 +19,7 @@
        ],
        "support": {
                "general": "https://typo3.org/support/",
-               "issues": "http://forge.typo3.org",
+               "issues": "https://forge.typo3.org",
                "irc": "irc://irc.freenode.net/#typo3-cms",
                "news": "nntp://lists.typo3.org"
        },
                "typo3/sysext/core/bin/typo3"
        ],
        "require": {
-               "php": ">=5.5.0",
-               "ext-fileinfo": "*",
+               "php": "^7.0",
+               "ext-json": "*",
                "ext-pcre": "*",
                "ext-session": "*",
                "ext-xml": "*",
-               "psr/log": "1.0.*@dev",
-               "pear/http_request2": "~2.2.1",
-               "swiftmailer/swiftmailer": "~5.4.1",
-               "symfony/console": "^3.0",
-               "symfony/finder": "^3.0",
+               "psr/log": "1.0.0",
+               "swiftmailer/swiftmailer": "~5.4.3",
+               "symfony/console": ">=2.7 <3.1",
+               "symfony/finder": ">=2.7 <3.1",
                "doctrine/instantiator": "~1.0.4",
                "typo3/class-alias-loader": "^1.0",
-               "typo3/cms-composer-installers": "^1.2.5",
+               "typo3/cms-composer-installers": "^1.2.8",
                "psr/http-message": "~1.0",
                "cogpowered/finediff": "~0.3.1",
-               "mso/idna-convert": "^0.9.1",
-               "typo3fluid/fluid": "^1.0.3"
+               "mso/idna-convert": "^1.1.0",
+               "typo3fluid/fluid": "^1.0.7",
+               "guzzlehttp/guzzle": "^6.2.1",
+               "doctrine/dbal": "~2.5.4"
        },
        "require-dev": {
-               "phpunit/phpunit": "~4.8.0",
-               "mikey179/vfsStream": "1.6.0"
+               "phpunit/phpunit": "^5.4",
+               "mikey179/vfsStream": "~1.6.0",
+               "codeception/codeception": "^2.2",
+               "se/selenium-server-standalone": "~2.53",
+               "7elix/styleguide": "~8.0.0",
+               "site5/phantoman": "^1.0",
+               "jakoch/phantomjs-installer": "2.1.1-p05",
+               "friendsofphp/php-cs-fixer": "^1.11"
        },
        "suggest": {
                "ext-gd": "GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images",
+               "ext-fileinfo": "Used for proper file type detection in the file abstraction layer",
                "ext-zlib": "TYPO3 uses zlib for amongst others output compression and un/packing t3x extension files",
                "ext-openssl": "",
                "ext-soap": "",
-               "ext-zip": ""
+               "ext-zip": "",
+               "ext-mysqli": ""
        },
        "extra": {
                "typo3/class-alias-loader": {
@@ -79,6 +88,7 @@
                "typo3/cms-beuser": "self.version",
                "typo3/cms-context-help": "self.version",
                "typo3/cms-core": "self.version",
+               "typo3/cms-compatibility7": "self.version",
                "typo3/cms-cshmanual": "self.version",
                "typo3/cms-css-styled-content": "self.version",
                "typo3/cms-dbal": "self.version",
                },
                "classmap": ["typo3/sysext/extbase/Tests/Unit/Object/Container/Fixtures/"]
        },
-       "include-path": [
-               "vendor/pear/http_request2/",
-               "vendor/pear/net_url2/"
-       ]
+       "scripts": {
+               "post-install-cmd": [
+                       "PhantomInstaller\\Installer::installPhantomJS"
+               ],
+               "post-update-cmd": [
+                       "PhantomInstaller\\Installer::installPhantomJS"
+               ]
+       }
 }