[TASK] Move bower dependencies to npm
[Packages/TYPO3.CMS.git] / Build / package.json
index 39868b2..9a072f1 100644 (file)
@@ -8,15 +8,27 @@
   "version": "9.0.0-dev",
   "license": "GPL-2.0+",
   "devDependencies": {
+    "@claviska/jquery-minicolors": "^2.2.6",
     "@types/bootstrap": "*",
     "@types/jasmine": "^2.5.35",
     "@types/jquery": "*",
     "@types/jqueryui": "*",
     "@types/nprogress": "*",
     "@types/requirejs": "*",
+    "@typo3/icons": "^1.4.1",
     "autoprefixer": "^6.3.7",
+    "autosize": "^3.0.20",
+    "bootstrap-sass": "^3.3.7",
+    "bootstrap-slider": "^9.7.3",
     "bower": "^1.8.0",
     "chosen-js": "^1.7.0",
+    "ckeditor": "^4.6.2",
+    "cropper": "^2.3.4",
+    "d3": "^4.7.4",
+    "datatables": "^1.10.13",
+    "devbridge-autocomplete": "^1.4.1",
+    "eonasdan-bootstrap-datetimepicker": "^4.17.47",
+    "font-awesome": "^4.7.0",
     "grunt": "~1.0.1",
     "grunt-bower-just-install": "0.0.3",
     "grunt-bowercopy": "^1.2.0",
     "grunt-svgmin": "4.0.0",
     "grunt-ts": "^5.5.1",
     "grunt-tslint": "^3.2.1",
+    "imagesloaded": "^4.1.1",
     "jasmine-core": "~2.6.0",
     "jquery": "^3.2.1",
+    "jquery-match-height": "^0.7.2",
+    "jquery-ui": "^1.11.4",
     "karma": "^1.3.0",
     "karma-chrome-launcher": "^2.0.0",
     "karma-coverage": "^1.0.0",
     "karma-phantomjs-launcher": "^1.0.0",
     "karma-requirejs": "^1.0.0",
     "karma-safari-launcher": "^1.0.0",
+    "moment": "^2.18.1",
+    "moment-timezone": "^0.5.13",
+    "nprogress": "^0.2.0",
     "phantomjs-prebuilt": "^2.1.7",
     "postcss-banner": "^3.0.0",
     "postcss-clean": "^1.0.2",
-    "requirejs": "^2.2.0",
+    "requirejs": "^2.3.3",
     "stylefmt": "^5.3.0",
+    "taboverride": "^4.0.3",
     "tagsort": "1.4.0",
     "tslint": "^3.15.1",
     "typescript": "^2.2.0"