[TASK] Upgrade typo3/phar-stream-wrapper to v3.1.3 (PHP 7.4)
[Packages/TYPO3.CMS.git] / typo3 / sysext / core / Documentation / Changelog / 8.0 / Deprecation-73067-DeprecateGeneralUtilityrequireOnceAndGeneralUtilityrequireFile.rst
index a6074ec..0b88655 100644 (file)
@@ -1,15 +1,20 @@
+
+.. include:: ../../Includes.txt
+
 ============================================================================================
 Deprecation: #73067 - Deprecate GeneralUtility::requireOnce and  GeneralUtility::requireFile
 ============================================================================================
 
 ============================================================================================
 Deprecation: #73067 - Deprecate GeneralUtility::requireOnce and  GeneralUtility::requireFile
 ============================================================================================
 
+See :issue:`73067`
+
 Description
 ===========
 
 Description
 ===========
 
-The following methods from ``TYPO3\CMS\Core\Utility\GeneralUtility`` have been
+The following methods from `TYPO3\CMS\Core\Utility\GeneralUtility` have been
 marked as deprecated.
 
 marked as deprecated.
 
-``GeneralUtility::requireOnce()``
-``GeneralUtility::requireFile()``
+`GeneralUtility::requireOnce()`
+`GeneralUtility::requireFile()`
 
 
 Impact
 
 
 Impact
@@ -28,3 +33,5 @@ Migration
 =========
 
 Use native require_once if needed, e.g. if autoloading does not work.
 =========
 
 Use native require_once if needed, e.g. if autoloading does not work.
+
+.. index:: PHP-API