[TASK] Update phpunit/phpunit to 8.3.3
[Packages/TYPO3.CMS.git] / composer.json
index 5de6c91..5109f7f 100644 (file)
                "ext-xml": "*",
                "cogpowered/finediff": "~0.3.1",
                "doctrine/annotations": "^1.3",
                "ext-xml": "*",
                "cogpowered/finediff": "~0.3.1",
                "doctrine/annotations": "^1.3",
-               "doctrine/dbal": "~2.8.0",
+               "doctrine/dbal": "^2.9",
                "doctrine/instantiator": "^1.1",
                "doctrine/lexer": "^1.0",
                "guzzlehttp/guzzle": "^6.3.0",
                "doctrine/instantiator": "^1.1",
                "doctrine/lexer": "^1.0",
                "guzzlehttp/guzzle": "^6.3.0",
-               "nikic/php-parser": "^4.0",
+               "nikic/php-parser": "^4.2",
                "phpdocumentor/reflection-docblock": "^4.3",
                "psr/container": "^1.0",
                "phpdocumentor/reflection-docblock": "^4.3",
                "psr/container": "^1.0",
+               "psr/event-dispatcher": "^1.0",
                "psr/http-message": "~1.0",
                "psr/http-server-middleware": "^1.0",
                "psr/log": "~1.0.0",
                "psr/http-message": "~1.0",
                "psr/http-server-middleware": "^1.0",
                "psr/log": "~1.0.0",
-               "swiftmailer/swiftmailer": "~5.4.5",
+               "symfony/config": "^4.1",
                "symfony/console": "^4.1",
                "symfony/console": "^4.1",
+               "symfony/dependency-injection": "^4.1",
                "symfony/expression-language": "^4.1",
                "symfony/expression-language": "^4.1",
-               "symfony/finder": "^4.1",
+               "symfony/finder": "^4.3",
+               "symfony/mailer": "^4.3",
+               "symfony/mime": "^4.3",
                "symfony/polyfill-intl-icu": "^1.6",
                "symfony/polyfill-intl-idn": "^1.10",
                "symfony/polyfill-mbstring": "^1.2",
                "symfony/polyfill-intl-icu": "^1.6",
                "symfony/polyfill-intl-idn": "^1.10",
                "symfony/polyfill-mbstring": "^1.2",
                "typo3/class-alias-loader": "^1.0",
                "typo3/cms-cli": "^2.0",
                "typo3/cms-composer-installers": "^2.0",
                "typo3/class-alias-loader": "^1.0",
                "typo3/cms-cli": "^2.0",
                "typo3/cms-composer-installers": "^2.0",
-               "typo3/phar-stream-wrapper": "^3.1.1",
+               "typo3/phar-stream-wrapper": "^3.1.2",
                "typo3fluid/fluid": "^2.6.1",
                "webmozart/assert": "^1.0"
        },
        "require-dev": {
                "typo3fluid/fluid": "^2.6.1",
                "webmozart/assert": "^1.0"
        },
        "require-dev": {
-               "codeception/codeception": "^2.5.4",
+               "codeception/codeception": "^2.5.4 || ^3",
                "friendsofphp/php-cs-fixer": "^2.12.2",
                "phpspec/prophecy": "^1.7.5",
                "typo3/cms-styleguide": "~10.0.2",
                "friendsofphp/php-cs-fixer": "^2.12.2",
                "phpspec/prophecy": "^1.7.5",
                "typo3/cms-styleguide": "~10.0.2",
-               "typo3/testing-framework": "~5.0.7"
+               "typo3/testing-framework": "~5.0.11"
        },
        "suggest": {
                "ext-gd": "GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images",
        },
        "suggest": {
                "ext-gd": "GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images",
                "ext-mysqli": ""
        },
        "conflict": {
                "ext-mysqli": ""
        },
        "conflict": {
+               "symfony/cache": "< 2.8.50 >= 2.8.0 || < 3.4.26 >= 3.4.0 || < 4.1.12 >= 4.1.0 || < 4.2.7 >= 4.2.0",
                "symfony/finder": "2.7.44 || 2.8.37 || 3.4.7 || 4.0.7",
                "symfony/routing": "4.2.7"
        },
        "extra": {
                "typo3/class-alias-loader": {
                "symfony/finder": "2.7.44 || 2.8.37 || 3.4.7 || 4.0.7",
                "symfony/routing": "4.2.7"
        },
        "extra": {
                "typo3/class-alias-loader": {
+                       "class-alias-maps": [
+                               "typo3/sysext/core/Migrations/Code/ClassAliasMap.php"
+                       ],
                        "always-add-alias-loader": true
                },
                "branch-alias": {
                        "always-add-alias-loader": true
                },
                "branch-alias": {
-                       "dev-master": "10.0.x-dev"
+                       "dev-master": "10.1.x-dev"
                }
        },
        "scripts": {
                }
        },
        "scripts": {