[TASK] Update CKEDITOR to 4.7.0
[Packages/TYPO3.CMS.git] / Build / package.json
index 6c70fe9..0c9f1fb 100644 (file)
@@ -10,6 +10,8 @@
   "devDependencies": {
     "@claviska/jquery-minicolors": "^2.2.6",
     "@types/bootstrap": "*",
+    "@types/ckeditor": "0.0.38",
+    "@types/imagesloaded": "^4.1.0",
     "@types/jasmine": "^2.5.35",
     "@types/jquery": "*",
     "@types/jqueryui": "*",
@@ -21,7 +23,7 @@
     "bootstrap-sass": "^3.3.7",
     "bootstrap-slider": "^9.7.3",
     "chosen-js": "^1.7.0",
-    "ckeditor": "^4.6.2",
+    "ckeditor": "^4.7.0",
     "cropper": "^2.3.4",
     "d3": "^4.7.4",
     "datatables": "^1.10.13",
     "grunt-contrib-copy": "^1.0.0",
     "grunt-contrib-uglify": "2.0.0",
     "grunt-contrib-watch": "~1.0.0",
+    "grunt-exec": "^2.0.0",
     "grunt-npm-install": "^0.3.1",
     "grunt-npmcopy": "^0.1.0",
     "grunt-postcss": "^0.8.0",
     "grunt-sass": "^2.0.0",
     "grunt-stylelint": "^0.7.0",
-    "grunt-ts": "^5.5.1",
-    "grunt-tslint": "^3.2.1",
+    "grunt-tslint": "^5.0.1",
     "imagesloaded": "^4.1.1",
     "jasmine-core": "~2.6.0",
     "jquery": "^3.2.1",
-    "jquery-match-height": "^0.7.2",
     "jquery-ui": "^1.11.4",
     "karma": "^1.3.0",
     "karma-chrome-launcher": "^2.0.0",
     "stylefmt": "^5.3.0",
     "taboverride": "^4.0.3",
     "tagsort": "1.4.0",
-    "tslint": "^3.15.1",
-    "typescript": "^2.2.0"
+    "tslint": "^5.4.2",
+    "typescript": "^2.3.4"
   },
   "scripts": {
     "build-css": "./node_modules/.bin/grunt css",
+    "build-js": "./node_modules/.bin/grunt scripts",
+    "build": "./node_modules/.bin/grunt build",
+    "format": "./node_modules/.bin/grunt format",
+    "update": "./node_modules/.bin/grunt update",
     "lint": "./node_modules/.bin/grunt lint"
   }
 }