[TASK] Allow multiple extractor services with the same priority
[Packages/TYPO3.CMS.git] / typo3 / sysext / core / Documentation / Changelog / 8.0 / Deprecation-73067-DeprecateGeneralUtilityrequireOnceAndGeneralUtilityrequireFile.rst
1
2 .. include:: ../../Includes.txt
3
4 ============================================================================================
5 Deprecation: #73067 - Deprecate GeneralUtility::requireOnce and  GeneralUtility::requireFile
6 ============================================================================================
7
8 See :issue:`73067`
9
10 Description
11 ===========
12
13 The following methods from `TYPO3\CMS\Core\Utility\GeneralUtility` have been
14 marked as deprecated.
15
16 `GeneralUtility::requireOnce()`
17 `GeneralUtility::requireFile()`
18
19
20 Impact
21 ======
22
23 Using aforementioned methods will trigger a deprecation log entry.
24
25
26 Affected Installations
27 ======================
28
29 Instances which use one of the aforementioned methods.
30
31
32 Migration
33 =========
34
35 Use native require_once if needed, e.g. if autoloading does not work.
36
37 .. index:: PHP-API