[TASK] Optimized rendering of Changelogs for docs.typo3.org
[Packages/TYPO3.CMS.git] / typo3 / sysext / core / Documentation / Changelog / 8.0 / Deprecation-73067-DeprecateGeneralUtilityrequireOnceAndGeneralUtilityrequireFile.rst
1
2 .. include:: ../../Includes.txt
3
4 ============================================================================================
5 Deprecation: #73067 - Deprecate GeneralUtility::requireOnce and  GeneralUtility::requireFile
6 ============================================================================================
7
8 Description
9 ===========
10
11 The following methods from `TYPO3\CMS\Core\Utility\GeneralUtility` have been
12 marked as deprecated.
13
14 `GeneralUtility::requireOnce()`
15 `GeneralUtility::requireFile()`
16
17
18 Impact
19 ======
20
21 Using aforementioned methods will trigger a deprecation log entry.
22
23
24 Affected Installations
25 ======================
26
27 Instances which use one of the aforementioned methods.
28
29
30 Migration
31 =========
32
33 Use native require_once if needed, e.g. if autoloading does not work.
34
35 .. index:: php