[TASK] Require "fluid" for "fluid_styled_content"
[Packages/TYPO3.CMS.git] / typo3 / sysext / fluid_styled_content / composer.json
1 {
2 "name": "typo3/cms-fluid-styled-content",
3 "type": "typo3-cms-framework",
4 "description": "A set of common content elements based on Fluid for Frontend output.",
5 "homepage": "https://typo3.org",
6 "license": ["GPL-2.0-or-later"],
7 "authors": [{
8 "name": "TYPO3 Core Team",
9 "email": "typo3cms@typo3.org",
10 "role": "Developer"
11 }],
12
13 "require": {
14 "typo3/cms-core": "9.2.*@dev",
15 "typo3/cms-fluid": "9.2.*@dev",
16 "typo3/cms-frontend": "9.2.*@dev"
17 },
18 "conflict": {
19 "typo3/cms": "*"
20 },
21 "replace": {
22 "fluid_styled_content": "*"
23 },
24 "extra": {
25 "branch-alias": {
26 "dev-master": "9.2.x-dev"
27 },
28 "typo3/cms": {
29 "Package": {
30 "partOfFactoryDefault": true
31 },
32 "extension-key": "fluid_styled_content"
33 }
34 },
35 "autoload": {
36 "psr-4": {
37 "TYPO3\\CMS\\FluidStyledContent\\": "Classes/"
38 }
39 },
40 "autoload-dev": {
41 "psr-4": {
42 "TYPO3\\CMS\\FluidStyledContent\\Tests\\": "Tests/"
43 }
44 }
45 }