[BUGFIX] Add conflicts to core extensions' composer.json
[Packages/TYPO3.CMS.git] / typo3 / sysext / lowlevel / composer.json
1 {
2         "name": "typo3/cms-lowlevel",
3         "type": "typo3-cms-framework",
4         "description": "TYPO3 Core",
5         "homepage": "https://typo3.org",
6         "license": ["GPL-2.0+"],
7
8         "require": {
9                 "typo3/cms-core": "*"
10         },
11         "conflict": {
12                 "typo3/cms": "*"
13         },
14         "replace": {
15                 "lowlevel": "*"
16         },
17         "extra": {
18                 "branch-alias": {
19                         "dev-master": "9.x-dev"
20                 },
21                 "typo3/cms": {
22                         "Package": {
23                                 "partOfFactoryDefault": true
24                         }
25                 }
26         },
27         "autoload": {
28                 "psr-4": {
29                         "TYPO3\\CMS\\Lowlevel\\": "Classes/"
30                 }
31         },
32         "autoload-dev": {
33                 "psr-4": {
34                         "TYPO3\\CMS\\Lowlevel\\Tests\\": "Tests/"
35                 }
36         }
37 }