[!!!][TASK] Remove deprecated class Package\DependencyResolver
[Packages/TYPO3.CMS.git] / typo3 / sysext / install / Configuration / Commands.php
1 <?php
2 /**
3 * Commands to be executed by typo3, where the key of the array
4 * is the name of the command (to be called as the first argument after typo3).
5 * Required parameter is the "class" of the command which needs to be a subclass
6 * of Symfony/Console/Command.
7 *
8 * example: bin/typo3 language:update
9 */
10 return [
11 'language:update' => [
12 'class' => \TYPO3\CMS\Install\Command\LanguagePackCommand::class
13 ],
14 'upgrade:run' => [
15 'class' => \TYPO3\CMS\Install\Command\UpgradeWizardRunCommand::class
16 ],
17 'upgrade:list' => [
18 'class' => \TYPO3\CMS\Install\Command\UpgradeWizardListCommand::class
19 ]
20 ];